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1. Getting Started with Black Ink

Welcome to Black Ink! In this chapter you will learn about the main features of the app, 
and how to download crossword puzzles from the web.

The Puzzle Window
Black Ink displays each puzzle in its own window, allowing you to work on more than 
one crossword at a time. Each window has the standard title bar, including controls to 
close, minimize, and switch to full-screen mode. Type the answers to the puzzle’s clues 
right into the grid. The Navigation section of this document describes the various ways 
you can move about the puzzle as you solve. The current clue is displayed above the 
puzzle grid, and highlighted in the clue list at the right side of the window. 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Opening Puzzles
Black Ink works with puzzle files in the Across Lite format. Search for puzzles on the 
web in this format, download them, and open them with the app. Black Ink also makes it 
easy to download the latest puzzle from some well-known puzzle sources. By default 
Black Ink displays a web puzzle browser dialog when it is first launched. Simply click on 
a puzzle source and you’ll be solving in moments!

At any time you may choose another web puzzle to solve by selecting “Open Web 
Puzzle” from the “File” menu. Both the launch-time browser and the Open menu contain 
all of the puzzle sources configured in Black Ink’s Preferences dialog. If you find another 
source on the web with a predictable download URL format, you can use Preferences to 
add it to the list. You can also reorder the list to put your favorite puzzle at the top!

If you have existing puzzle files on your computer, simply choose the “Open” item from 
the “File” menu to choose the puzzle file.  Black Ink even provides an “Open as 
Unsolved” menu item in the “File” menu, useful for replaying old puzzles.

Navigation
Black Ink provides a number of ways to navigate within the puzzle. Many of the  
navigation mechanisms are directly affected by user preferences. (See the Preferences  
section of the Configuration chapter for more information.) When a puzzle is opened, 
the first word is selected, usually 1 across. The selected word is always highlighted with 
the highlight color from your Mac’s System Preferences. The focused square is 
identified by a darker shade of the highlight color. The grid itself is composed of white 
and black squares. White squares are active and can contain user typed characters. 
Black squares are inactive and cannot be modified.

Mouse Navigation
Use the mouse to quickly move to any portion of the puzzle. A single click anywhere 
within the puzzle grid will move focus to that square. Clicking the already-focused 
square changes the orientation of the selected word, if possible. For example if the 
square at 1 across is also part of a 1 down word, focus would shift from across to down.

Whenever focus changes, the selected clue is updated to match the focused square 
and orientation. You can also change the focused square and selected word by 
selecting a clue from either the across or down list in the clue list drawer. The default 
preferences specify that focus will jump to the first empty square in a word when you 
select a word from the clue list.

Keyboard Navigation
The main mechanism for interacting with the crossword puzzle grid is the keyboard. The 
default action when you type a letter is to fill the focused square with that letter and to 
move focus to the next empty square in the word. This movement can be disabled or 
modified in Preferences.
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Use the arrow keys to change focus without entering an answer. When navigating with 
arrow keys, the selected orientation and word can be changed by altering the direction 
of movement from horizontal to vertical or vice versa. For example, if the focused 
square is part of both an across and down answer, pressing the down arrow key will 
change the orientation from across to down. By default, the focused square does not 
change, but this behavior is also controlled by a preference.

Use the tab key or return key to quickly move to the next word for the current 
orientation. Use shift-tab to move to the previous word for the current orientation.

Direct Word Navigation
To navigate immediately to a specific numbered square, simply type the number. For 
example, to move from 1 across to 85 down you would simply enter 85 and press 
Return. As you type, the numbers will appear in a visual display above the puzzle grid. 
Press the Escape key to cancel a partially entered number.

OneAcross.com Lookup
Black Ink makes it easy to search the OneAcross (http://www.oneacross.com/) online 
clue database. The OneAcross system connects clue text to crossword solutions. The 
service is free, with a suggested donation of $20 per year. The “Answer Pattern” 
specifies the number of letters in the word, and any letters that may be in the word 
positionally. For example, if there was a 4 letter word and the middle two letters were 
“NC”, the pattern would be “?NC?”. Black Ink will fill in the clue text, build the pattern 
based on the existing puzzle board contents, and display this in a window. The pattern 
and clue text can be changed before sending a query. When the query is sent, it will 
open your default browser and display the result page. Your browser is used to comply 
with the OneAcross usage guidelines. If you use this functionality regularly, please 
make a donation to OneAcross through their web site.
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Puzzle Timer
Black Ink includes an optional timer for tracking how long it takes you to solve a puzzle. 
By default the timer runs from the moment you open a puzzle until the moment you 
enter or reveal the final correct answer. The timer is paused automatically when you 
switch from Black Ink to another app, or when you switch between open puzzles in 
Black Ink.

Menus
The menus in Black Ink are a combination of standard application menus and Black Ink-
specific menus. Items of interest are described in detailed below.

Black Ink menu
The Black Ink menu is used to access functionality that affects the application as a 
whole. Standard Mac menu items such as Services, Hide, and Quit are not described 
here.

File menu
The File menu is used for opening, saving, and printing puzzles.

Menu Item Purpose

About Black Ink Displays credits and information about Black Ink.

Registration… Displays information about your purchase of a Black 
Ink license.

Check for Updates In versions of Black Ink that were not purchased from 
the Mac App Store, this option checks for an updated 
version of the app from Red Sweater’s web site.

Preferences… Displays the Preferences window for Black Ink. See 
the Preferences section of the Configuration chapter 
for detailed information.

Menu Item Purpose

Open Web Puzzle A submenu appears with a list of your configured and 
enabled web puzzle sources. Select a source to 
download the latest puzzle and begin working on it.

Show Web Puzzle 
Chooser

Displays a window with the same puzzle sources as in 
the submenu above. This window is optionally 
displayed by default when Black Ink opens.
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Edit menu
The Edit menu is used to perform a variety of text manipulation actions on the board of 
the active puzzle window.

Open Puzzle File… Opens a crossword puzzle file. The file must be an 
Across Lite format file.

Open Recent Opens a recently opened crossword puzzle file as 
selected from its sub menu. The list of recent items 
can be reset by selecting “Clear Menu.”

Close Closes the active puzzle window.

Save Saves the active puzzle window with its existing 
name.

Duplicate Saves a copy of the active puzzle window with a new 
name.

Revert To Presents a submenu with options for reverting to an 
earlier version of a puzzle.

Page Setup… Provides the ability to modify standard page layout 
settings for the currently active crossword puzzle in 
preparation for printing. Page Setup also contains 
Black Ink-specific printing options. See the “Print 
Options” section in the Configuration chapter for more 
information.

Print… Prints the active puzzle window, allowing standard 
printer settings to be modified.

Menu Item Purpose

Menu Item Purpose

Start Over… Opens a crossword puzzle file, clearing any previous 
answers before displaying it. Useful for resolving a 
previously completed puzzle.

Enter Special 
Answer

When puzzles require special answers such as multi-
letter answers or special characters, this menu item 
facilitates the entry of such answers.
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View menu
The View menu is used to adjust the appearance of the active puzzle window.

Undo Changes the puzzle back to the state just prior to the 
last action. The name of this menu item will be 
appended with text to identify what the action was.

Redo Negates the effect of a previous Undo action.

Cut Word Cuts the active word, causing the squares to be 
emptied and the cut text to be added to the system 
pasteboard.

Copy Word Copies the text of the active word into the system 
pasteboard.

Paste Word Pastes available text from the system pasteboard into 
the active word. If the available text is longer than the 
active word, it will be trimmed before insertion into the 
board. This action will replace any existing text in the 
active word.

Clear Word Clears the active word, causing the squares to be 
emptied.

Menu Item Purpose

Menu Item Purpose

Make Puzzle Bigger Increases the size of the puzzle window. The window 
cannot be made larger than the Mac’s screen can fit.

Make Puzzle 
Smaller

Decreases the size of the puzzle window.

Show/Hide Clue 
Lists

Toggles the display of the drawer containing the 
puzzle clue lists for Across and Down. The menu 
name will be modified to reflect the effect of selecting 
it.
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Show Puzzle 
Notes…

Displays a popup window containing the text of the 
puzzle notes. The popup window can be clicked and 
dragged away from the puzzle window to keep it 
visible while you solve. This menu item will be 
disabled if there are no notes for the active puzzle.

Show/Hide Puzzle 
Timer

Shows or hides the puzzle timer section of the active 
puzzle window.

Enter Full Screen Moves the active puzzle window into full-screen mode.

Menu Item Purpose
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Solution Menu
The Solution menu contains actions that are related to the puzzle solution, some of 
which are only available if the puzzle is unscrambled.

Menu Item Purpose

Check Current 
Letter

Compares the letter at the focused square to the 
correct answer, if known. The square will be marked 
as checked, according to the Square State 
appearance preferences.

Check Current 
Word

Performs “Check Current Letter” on each square in 
the focused word.

Check Entire 
Puzzle

Performs “Check Current Letter” on each square in 
the entire puzzle.

Reveal Current 
Letter

Reveals the correct answer for the focused square, 
and marks the character as having been revealed. 
The square will be marked as revealed, according to 
the Square State appearance preferences. Once a 
square has been revealed it cannot be changed.

Reveal Current 
Word

Performs “Reveal Current Letter” on each square in 
the focused word.

Reveal Incorrect 
Letters

Performs “Reveal Current Letter” on each square in 
the puzzle which currently has an incorrect answer.

Reveal Entire 
Puzzle

Performs “Reveal Current Letter” on each square in 
the entire puzzle.

OneAcross.com 
Lookup…

Displays the OneAcross Lookup prompt, pre-
populated with the clue and answer text for the 
selected word. See the OneAcross Lookup section 
above for more information.
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Window Menu
The Window menu is used to navigate among Black Ink’s various windows.

Help Menu
The Help menu provides quick access to user documentation and support.

Menu Item Purpose

Web Puzzle 
Chooser

Displays the menu of web puzzle sources available, in 
an easily clickable window.

Minimize Shrinks the puzzle window and places it in the Dock.

Zoom Toggles the window size between the largest 
reasonable size for the current screen, and the size 
you last set the window to.

Bring All to Front Brings all Black Ink windows to the foreground, in front 
of windows from other applications on your Mac.

Menu Item Purpose

Black Ink User 
Guide

Displays this user guide.

Contact Support Opens the Red Sweater support page, which includes 
options for browsing online help or contacting us for 
support.

Acknowledgements Displays a window showing acknowledgements for 
third-party source code that is used with permission in 
Black Ink.
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Special Answer Entry
Some crossword puzzles are created with themes that require multiple letters or special 
characters in a single square. Typing a letter in a square normally advances the input 
location to the next square in the word, so to enter special answers Black Ink features a 
separate input mechanism. To enter a special answer, you may either control-click the 
square you wish to enter into, or select “Enter Special Answer” from the Edit menu.  An 
enlarged input area will appear, allowing the entry of however many letters are needed:

To end editing press the return key. Note that it is possible to press return with an empty 
input area if entering multiple letters was not intended or to delete previously entered 
letters. For puzzles that contain multiple letter square answers the check and reveal 
functionality will take that information into account. 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2. Configuration

This chapter details the configuration of Black Ink.
Black Ink has many configuration options, allowing a fine-tuned solving experience.

Preferences
Use Black Ink Preferences window to customize some of the display and behavioral 
characteristics of the app. Preferences are broken into four categories: Appearance, 
Startup, Solving, and Web Puzzles. Select Preferences from the Black Ink menu to 
open the window.

Appearance Preferences
Appearance preferences are concerned with visual aspects of Black Ink.

The Square Status section of the Appearance pane controls the visual feedback Black 
Ink uses to convey information about the way a square was solved. As you solve, 
check, or reveal puzzle squares, information about the correctness of the square can be 
displayed either by a small symbol, or by a custom coloring of the answer text. The 
preview “DEMO” squares give immediate feedback about how the settings will look 
while solving a puzzle.
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A “Corrected” square is one whose value has been confirmed as the correct answer, 
after having been previously marked “Incorrect” by one of the “Check” menu items in the 
“Solution” menu. 

An “Incorrect” square is one whose value has been found to be different from the 
correct answer, after being checked with one of the “Check” menu items in the 
“Solution” menu. 

A “Revealed” square is one whose correct value has been supplied by Black Ink, using 
one of the “Reveal” menu items in the “Solution” menu.

Startup Preferences
Startup preferences deal with the behavior of Black Ink upon launching. Use these set-
tings to adjust the behavior according to your puzzle solving & downloading style.

By default Black Ink will re-open any puzzles that were open when the app was last 
closed. If no puzzles were left open, the app can automatically prompt you to open a 
new puzzle from the web, or a puzzle file that you have saved to your computer.

For versions of the app that were not purchased from the Mac App Store, the “Software 
Update” option can be used to check for an updated version of the app, or to configure 
automatic, periodic checks.
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Solving Preferences
Solving preferences include options for the puzzle timer, automatic error correction, and 
for adjusting the mechanics of square focus while solving a puzzle.

Select the “Start the timer” option if you want Black Ink to show and start the puzzle 
timer immediately upon opening a puzzle document. See the Puzzle Timer section for 
more information about this feature.

Select the “Show puzzle notes if present” option to automatically display puzzle notes 
that are associated with a puzzle. These are sometimes used to provide hints about the 
theme of a puzzle or to give credit to people who were involved in constructing the puz-
zle.

Options in the Square Focus section are used to control how the focused square 
changes when various actions occur. The “Change focus after entering a letter” 
checkbox enables or disables the selection of a movement mechanism. If this checkbox 
is unchecked, the focused square will not change when a letter is typed on the 
keyboard; you will move the focused square manually with the mouse or with arrow 
keys. If the checkbox is checked, one of two mechanisms will be used to determine how 
the focused square changes. The “To next blank in word” option causes focus to move 
to the next blank square in the word, or simply to the next square if there are no more 
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blank squares. If “To next square in word” is selected, focus will always move to the next 
square in the word, regardless of its content. 

“Move to blank after switching direction” causes focus to move to the first blank square 
in a word when the orientation is toggled via a mouse action.

“Move to blank after changing words” causes focus to move to the first blank square in a 
word after you move to a new word using tab, shift-tab, return, or by clicking a clue in 
the clue list.

“Pause on direction switch via arrow keys” defines the behavior when you change 
orientation by pressing an arrow key. As outlined in the Keyboard Navigation section, 
the selection orientation and selected word can be changed by changing the direction of 
movement from horizontal to vertical or vice versa. When this preference is checked, 
the orientation will toggle, but the focused square will not change (unless it is necessary 
in order to facilitate an orientation switch). When it is unchecked, the orientation 
changes, and focus moves to the next square in the word.

“Show incorrect letters as I type them” allows you to be alerted immediately when you 
make a mistake while solving a puzzle. Most puzzles include answers, but this 
preference is not applicable to puzzles where no answers are embedded in the puzzle 
file. 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Web Puzzles
Use the Web Puzzles pane to manage the list of puzzles that Black Ink knows how to 
download on your behalf. 

Puzzles that are checked as “Enabled” appear in both the Web Puzzle Chooser and in 
the Open Web Puzzle menu. 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Print Options
Black Ink supports a variety of printing-related options. These options are accessible 
from within the Print panel, which appears when you select “Print” from the “File” menu. 
Click the “Show Details” button if Black Ink’s custom options are not already visible.

The “Fit printout to a single sheet of paper” option ensures that no matter how large the 
puzzle, or how many clues it has, it will only use one sheet of paper to print.

Ink Saver allows you to specify a gray value between Black and Light Gray in which the 
crossword grid should be printed. The closer the slider is positioned to Light Gray, the 
lighter the printed grid will be. Printing with a lighter color should reduce the amount of 
ink required to print the grid on paper.

Puzzle Content options allows you to control precisely what will be included in the 
printed puzzle, and how it will be laid out on the page. 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3. Spotlight Integration

This chapter explains Black Ink’s integration with Spotlight.
Black Ink provides indexing for puzzle files so Spotlight can be used to find them.

macOS includes a system-wide search functionality named Spotlight. Spotlight frees 
you from remembering where files are stored by means of a powerful indexing engine. 
When installed Tiger provides support for many common file formats.

Third party applications like Black Ink that utilize special file formats like Across Lite 
must provide assistance to Spotlight in order to properly index files. Support for 
Spotlight is bundled with Black Ink and you need only run Black Ink once for indexing of 
crossword puzzles to occur. After the initial run any new puzzles will be indexed 
automatically as long as Black Ink is still installed on the computer.

Search Examples
Black Ink provides Spotlight with puzzle title, author, and copyright information. In 
addition all puzzles are identified as being in AcrossLite format. It is possible to perform 
searches using any or all of these items.

Finding All Puzzles
To locate all the crossword puzzles on your computer you can simply enter 
“AcrossLite” (without quotes) into the Spotlight search field.

Finding Puzzles By Author
To locate all the crossword puzzles by a particular author you can simply enter the au-
thor’s name into the Spotlight search field.

More Information
For more information about Spotlight visit Apple’s website at http://www.apple.com/ma-
cosx/features/spotlight/  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Apple, the Apple logo, Mac, and Macintosh are trademarks of Apple Computer, Inc., 
registered in the U.S. and other countries. Across Lite is a trademark of Literate 
Software Systems. Black Ink is a trademark of Red Sweater Software. All other 
trademarks, service marks, and trade names belong to their respective owners.

Copyright © 2007-2018, Red Sweater Software.
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