»

MarsEdit 1.1.7

March 26th, 2007

MarsEdit 1.1.7 is available for download.
Another round of “minor but infuriating” bugs have been made history. Hope there’s something here for you to celebrate!

Note: The short-lived 1.1.6 update was quickly updated to 1.1.7. The changes below describe the fixes that went into 1.1.6. The change for 1.1.7 was a very small fix for posting to Blogger-based weblogs.

  • Fix bug where Custom Tag menu shortcuts disappear after adding or editing
  • Remember “Check Spelling as You Type” setting across launches
  • Little fixes
    • Fix a bug preventing the very last post in a weblog from being deleted
    • Fix some small memory leaks
    • Add Window -> Zoom menu item for consistency with other apps
    • Eliminate a pointless beep that could happen when closing weblog settings
    • Show scrollbar only when needed for Extended, Excerpt, and Keywords views
  • Blogger Specific
    • Fix “Blank category” bug for blogs with no categories
    • Filter authorization info from RPC console, for security protection
    • Fix to work with gmail passwords with special chars (‘&’, ‘=’, ‘+’, ‘?’, ‘/’) in them
  • Blosxom Specific
    • Fix Delete post functionality
  • Drupal Specific
    • Defaults to MovableType API for better user experience
    • Add help page documentation for “Getting Started”

5 Responses to “MarsEdit 1.1.7”

  1. Jan Says:

    > Fix a bug preventing the very last post in a weblog from being deleted

    good one :-)

  2. paul Says:

    I’m not sure if it’s a result of today’s update, or it happened earlier, but today I noticed that the live preview is painfully slow, and MarsEdit is no longer capable of displaying embedded Flash video (YouTube) in the preview window.

  3. Daniel Jalkut Says:

    Hi Paul – I haven’t done anything to the live preview for this release, but I am aware that it is often painfully slow. I am going to look into whether there are some performance tricks I can apply to make it more palatable.

    You might want to try turning off live preview. The preview still updates pretty darned frequently even when live preview is off. It’s just not re-rendering the web content everytime you type a new character.

    Do you have any idea when the Flash video content stopped working? It might be related to whether the “JavaScript” support is on for the preview window. So double-check that setting in “HTML Display” preferences.

  4. paul Says:

    OK… I’m an idiot. You are correct, Daniel. Plugins, Java, and Javascript were not enabled. I normally blog from my desktop (dual 2.0 GHz G5), and I have everything set up the way I like it. I’m traveling right now with my laptop (1.33 GHz G4 iBook), and mistakenly thought I had already set it up the same way. Everything is displaying now that they are enabled.

    The difference in processor is also probably why I never noticed an issue with Live Preview.

    Thanks for the quick reply.

  5. Daniel Jalkut Says:

    Great news, paul. Hopefully one day I can make the live preview scream even on a PB G4 :) But yeah it will definitely run better on your Dual G5!

Comments are Closed.

Follow the Conversation

Stay up-to-date by subscribing to the Comments RSS Feed for this entry.